Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 15, 2025 - 21:00 UTC
Scheduled
Window Start Time: Wednesday, January 15, 2025 21:00 UTC Window End Time: Thursday, January 16, 2025 01:00 UTC Expected Impact: < 2 hour Reason: We have received notification from the supplier that we need to perform Router software and switch software/hardware updates to enhance security and stability within this time.
Posted Dec 27, 2024 - 23:18 UTC
This scheduled maintenance affected: Data Centers (Hong Kong, HK).